Casio CZ-1000: RAM´s cartridge slot does not work

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

Casio CZ-1000: RAM´s cartridge slot does not work

Postby K-man » Thu Jun 14, 2018 9:46 pm

Hi

I have recently purchased a Casio CZ-1000. It´s in excellent condition, but I can´t use the RAM cartridge. When I push the "cartridge" button, the led´s indicator does not turn on, and either there is no message on the display saying "NOT READY - INSERT CARTRIDGE" as it should be. It´s completely dead.

Any suggestions, please??

Thanks
K-man
Newbie
Newbie
 
Posts: 19
Joined: Sat May 23, 2015 8:28 am
Location: Spain
Gear: Casio CZ1000 - Kawai K4 - Korg DS8

Re: Casio CZ-1000: RAM´s cartridge slot does not work

Postby Rasputin » Fri Jun 15, 2018 3:49 am

If it was an electrical problem tied to the keys then 7 or 8 other keys wouldn't work. If only the Cartridge button is not responding then it's very likely worn out contacts or some contaminate like pet hair or Pepsi Cola residue, etc.

Even if it was a bad trace then it would have to be in a very particular spot to knock out just the Cart button. That rules out bad joiner cables between PCBs as well.

To reiterate the cartridge loading/saving routine: Turn off memory protection, hold down WRITE and press CARTRIDGE and then (while still holding WRITE) press a number. If "---NOT READY---- | INSERT CARTRIDGE" does not appear then I'd almost 100% say you've got a physically bad Cartridge button (assuming that same write procedure works for internal memory).

Should be easy to fix with a little cleaning, or--worst case scenario--a little Caikote.
Rasputin
Active Member
Active Member
 
Posts: 614
Joined: Thu Jul 21, 2016 4:52 am


Return to HELP!

Who is online

Users browsing this forum: No registered users and 12 guests