Weird noise from Roland JX3p

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
mcoolf
Newbie
Newbie
Posts: 12
Joined: Wed Jan 11, 2017 12:16 pm

Weird noise from Roland JX3p

Post by mcoolf » Fri Oct 30, 2020 12:06 pm

I have this Roland JX3p and I hear weird cracking noise when I turn on the Chorus

and it's way less but I still hear when I turn off the chorus

I've recently replaced the Chorus chip cause of loud chorus noise and it's totally different type of noise.

please check the link below and let me know if anyone have any idea

https://www.dropbox.com/s/o1sg6dyfu9fqw ... 2.mp3?dl=0

User avatar
meatballfulton
Moderator
Moderator
Posts: 6248
Joined: Wed Apr 13, 2005 9:29 pm
Gear: Logic Pro X

Re: Weird noise from Roland JX3p

Post by meatballfulton » Fri Oct 30, 2020 2:11 pm

Might be a bad capacitor in the audio path...but IDing which one will take a while.
I listened to Hatfield and the North at Rainbow. They were very wonderful and they made my heart a prisoner.

synzoneau
Newbie
Newbie
Posts: 11
Joined: Sat Aug 31, 2019 4:16 am

Re: Weird noise from Roland JX3p

Post by synzoneau » Sat Nov 21, 2020 8:56 am

I've done a lot of these, take it to a tech he needs to change the muting transistors which are 2SC2878A type. This affects a lot of Junos as well. If yours has any 2SC2603 or 2SA1115 in the chorus board they're obvious because they're the small ones marked "603" or "115" they should be changed too with 2SC1815/2SA1015 instead

Post Reply