Ensoniq SD-1 Just Stopped Powering Up

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.
Post Reply
rohtarin
Newbie
Newbie
Posts: 2
Joined: Sun Jun 06, 2021 4:15 am

Ensoniq SD-1 Just Stopped Powering Up

Post by rohtarin » Sun Jun 06, 2021 4:28 am

This keyboard had been working fine, but it has been a few months since it was turned on. I replaced the floppy drive with a card reader a few years ago and that's been fine. Its most been in one spot for the past year or so. I just moved it a couple if days ago, plugged it in, and now the card reader powers ups, but the display is blank. No lights on any of the buttons. If I turn it off and immediately turn it back on, the display flashes with asterisks across it, but then goes blank again. The brightness of the display is dependent on how long the power is off before I turn it back on. I'm worried that where it was it might have got some condensation (near a window and an air vent now that I think about it). I had something similar happen 25 years ago or more and they had to replace one of the boards I think. Any idea where to start checking this out?

Rasputin
Senior Member
Senior Member
Posts: 823
Joined: Thu Jul 21, 2016 4:52 am

Re: Ensoniq SD-1 Just Stopped Powering Up

Post by Rasputin » Sun Jun 06, 2021 11:23 am

rohtarin wrote:
Sun Jun 06, 2021 4:28 am
This keyboard had been working fine, but it has been a few months since it was turned on. I replaced the floppy drive with a card reader a few years ago and that's been fine. Its most been in one spot for the past year or so. I just moved it a couple if days ago, plugged it in, and now the card reader powers ups, but the display is blank. No lights on any of the buttons. If I turn it off and immediately turn it back on, the display flashes with asterisks across it, but then goes blank again. The brightness of the display is dependent on how long the power is off before I turn it back on. I'm worried that where it was it might have got some condensation (near a window and an air vent now that I think about it). I had something similar happen 25 years ago or more and they had to replace one of the boards I think. Any idea where to start checking this out?
Power up to the blank display. Press random buttons on the SD-1 front panel. Do characters show up on the SD-1 display? If so, do some research about self-test mode -- it's a common Ensoniq fault.

rohtarin
Newbie
Newbie
Posts: 2
Joined: Sun Jun 06, 2021 4:15 am

Re: Ensoniq SD-1 Just Stopped Powering Up

Post by rohtarin » Sun Jun 06, 2021 6:26 pm

I tried that last night. I'll try it again and see if I get anything. How do you get it out of self test mode if that's the case? What could it mean if no characters show up?

I opened it up and nothing looks visibly damaged. No water marks, no scorching, etc. I do know the cats kept jumping in it, but I didn't see any signs that they did any damage.

Post Reply